Blog : retour d'expérience et souhaits

TipOTipO Messages 188Moderateur
Bonjour,
après le report d'une série de billets (par copier-coller depuis un blog WordPress), j'ai quelques interrogations :
- dans un billet de blog, comment positionner l'image au-dessus du texte et non à gauche ? Pas assez de CSS coulant dans mes veines pour trouver les bonnes règles.
- respect des dimensions de l'image, pour éviter tout agrandissement. Je prépare en effet mes photos en amont aux dimensions maximales que je souhaite publier. J'ai dû choisir "Grande" pour éviter les déformations.
- possibilité de choisir la longueur du texte des billets de blog dans la page (nb de mots, de caractères…)
- réglage global des commentaires : ils sont ouverts par défaut. Je fais le choix de les fermer, ce qui oblige à un clic systématique plus bas dans la page (l'écran de 15" oblige à défiler la page). Plutôt que les modifier un à un à coups de fastidieux clics, j'ai fait un remplacement à postériori dans le fichier *module.json*.
- report des dates de publication originelles : là, pas d'autre choix que d'y aller à la main. C'est long et source de TMS…

Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
Migration en préparation…

Commentaires

  • SylvainSylvain Messages 317Invité
    Bonjour @TipO
    dans un billet de blog, comment positionner l'image au-dessus du texte et non à gauche ?
    Les réglages intégrés sont gauche ou droite, pour des souhaits différents tu peux choisir l'option 'Masquer l'image dans l'article' et positionner ton image avec l'éditeur de pages, qui en plus respectera les proportions de ton image !

    possibilité de choisir la longueur du texte des billets de blog dans la page (nb de mots, de caractères…)
    C'est une idée, pour l'instant l'aperçu de l'article est limité à la hauteur de l'image.

    Bonne soirée
    Sylvain



  • TipOTipO Messages 188Moderateur
    Bonsoir @Sylvain ,
    merci pour les suggestions, ça m'aidera à mieux Zwiifter (!) en connaissance de cause.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    Bonjour @TipO
    Retraiter les images en amont de la publication est une saine précaution autant pour les articles de blog que pour toutes les autres images publiées.
    Quant au réglage des commentaires, un autre utilisateur souhaiterait des choix différents des tiens, il n'y a pas vraiment de bonne option par défaut en la matière.

    The f....g boss
  • TipOTipO Messages 188Moderateur
    Bonjour,
    on est bien d'accord @fred
    Pour les commentaires, en effet, c'est bien pour ça que j'ai signalé ma pseudo méthode de modification à postériori, je ne pensais pas à un changement à ce niveau, d'autant que la forme blog est ouverte aux commentaires par définition.

    Pour ma part, je dois limiter les clics à répétition, pour éviter les TMS –qui me guettent en permanence…


    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • TipOTipO Messages 188Moderateur
    Bonjour,

    je continue mes découvertes du fonctionnement du module, et par suite mes questions, mes attentes.

    Quand je reviens sur un article pour y apporter un changement mineur, tel qu'une correction typographique ou d'orthographe, ou si je cherche à améliorer des publications antérieures, la date de publication est systématiquement mise à jour. Comment faire pour ne pas changer celle-ci ? Ça modifie la chronologie des articles, ce qui me pose problème.

    Bien que cela ne soit pas la procédure normale de gestion du site, je n'ai trouvé que l'intervention dans le fichier *module.json*. Les dates au format Unix ne facilitent pas la maintenance "en coulisses". Dans le contexte de la migration [auto]manuelle à laquelle je me prépare, le travail est notablement alourdi.

    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • SylvainSylvain Messages 317Invité
    5 janv. modifié
    Bonjour @TipO

    Quand tu modifies un article de blog la date de publication est mise à jour mais tu as toujours la possibilité d'en sélectionner une autre, par exemple la date originale de l'article.

    Bonne journée
    Sylvain
  • TipOTipO Messages 188Moderateur
    5 janv. modifié
    Bonjour,
    j'avais bien vu @sylvain et c'est ça qui me pose problème.
    Si je comprends bien, rien ne permet de contourner ou de désactiver cette mise à jour systématique dès qu'on édite un article.
    Faudra que je m'en méfie à l'avenir.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    6 janv. modifié
    Bonjour,
    Un article de blog n'est pas censé être édité. Les corrections devraient être précisées avec des mentions (edit), le texte effacé devrait être barré. Et donc la date de création, ne devrait pas changer.
    Lors de l'édition d'un article, le champ date est initialisé avec time() au lieu de reprendre la valeur initiale, je le corrigerai dans la prochaine mise à jour.
    En attendant, il suffit de corriger le fichier /module/blog/view/edit.php et de remplacer la ligne 92 : 

    'value' => time()

    par 
    'value' => $this->getData(['module', $this->getUrl(0), 'posts', $this->getUrl(2), 'publishedOn'])

    Post edited by fred on
    The f....g boss
  • TipOTipO Messages 188Moderateur
    6 janv. modifié
    Merci @fred, ça fonctionne impeccablement.
    Post edited by TipO on
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    Bonjour,
    Tu as raison, problème corrigé dans 11.3
    Je déplace dans les bugs.
    The f....g boss
  • TipOTipO Messages 188Moderateur
    15 mars modifié
    Bonjour,
    j'ai tenté de comprendre comment améliorer la présentation des articles de blog dans la page index.
    La structure titre>image>corps de l'article donnait un résultat qui ne me satisfaisait pas.
    Pour illustrer mon propos, ci-joint une capture d'écran.

    Je ne sais si la future version changera ce fonctionnement, mais en attendant, j'ai préféré revoir ma structure d'article, désormais image>titre>corps de l'article.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    Voici en primeur la nouvelle version de blog (v6) la disposition moderne s'applique dans les paramètres puis disposition de la liste des articles.




    The f....g boss
  • TipOTipO Messages 188Moderateur
    16 mars modifié
    Merci @fred.
    Mes premiers tests sur une installation fraiche, avec données exemple, affichent une page blanche quand je veux configurer le module. Le débogueur mentionne une erreur 500, dont je peine à trouver la cause.
    Edit : je peux modifier un article, puis la page 'config' s'affiche toujours aussi blanche.
    Navigateur Firefox 78.15.0esr (64 bits), je ne peux plus aller au-delà, Mac trop vieux…

    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    Je retesterai, cette version n'est pas prévue tourner sur la version de Zwii actuelle. Des news demain.
    The f....g boss
  • fredfred Messages 709Administrateur
    16 mars modifié
    Le module Blog ci-dessous fonctionne correctement avec le Zwii actuel.

    Il y a eu des corrections selon les ordres de headings, une amélioration de la présentation et surtout un mode article complet qui permet au module de ressembler à un blog standard. Cependant, pour la compatibilité, le mode réduit est conservé, mais l'image de couverture n'est plus obligatoire.

    Il peut rester des notices et des warnings de-ci de-là, je n'avais pas prévu de le livrer aussi vite.

    Merci de vos retours.
    blog.7z 24.8K
    The f....g boss
  • TipOTipO Messages 188Moderateur
    Bonjour,

    encore merci @fred, celle-ci fonctionne correctement, ça va m'aider à progresser. Je vais retravailler mes mises en page pour avoir une présentation satisfaisante.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    Que penses-tu des nouvelles options et notamment de la présentation moderne ? J'ai prévu d'ajouter des id afin de faciliter la personnalisation au niveau de style et éventuellement du jquery.
    The f....g boss
  • TipOTipO Messages 188Moderateur
    À première vue, c'est très plaisant.
    Je n'ai pas encore tout exploré, je compte injecter mes articles pour comparer avec la version précédente. Je dois explorer diverses options pour voir comment donner un aspect à ma main.
    Effectivement, si la personnalisation via les styles est plus aisée, je suis preneur. CSS commence à m'être plus familier. jquery reste une terra incognita
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • TipOTipO Messages 188Moderateur
    Bonjour @fred,

    la combinaison Zwii 11.3.07 et blog V6 fonctionne impeccablement. Ça ressemble de plus en plus à ce que j'ai envie de faire.
    Pour information, je sais bien que tout cela est en cours de développement. Avec le module blog V6, la version 11400dev ne fonctionne pas du tout, j'ai une page blanche.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    26 mars modifié
    Oh il doit y avoir une fonction arrayCollum qui traîne, je la testerai, sachant que cette v6 était prévue pour Zwii 12. 
    The f....g boss
  • TipOTipO Messages 188Moderateur
    26 mars modifié
    Je confirme, je la retrouve dans le module blog V6.0 dans la 11.3.07.
    Il n'y a pas d'urgence, je teste ce que tu postes sur la forge et si ça coince, j'attends.
    Merci pour ce gros boulot, tu avances à une sacré cadence.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • TipOTipO Messages 188Moderateur
    15 juin modifié
    Bonjour,

    dans le fichier '/module/blog/view/index/index.css', le formatage de '.blogDate' contient une coquille : manque une espace dans la ligne 'font-size:0.8em;'


    Par ailleurs, je trouverais plus sympa des dates mises au format classique –dans le contexte français du moins, pour les premiers jours du mois : 
    1^er^ juin et non 01 juin, 2 juin et non 02 juin, etc.

    J'ai essayé sans succès les formats trouvés sur php.net.
    Qui pourrait me mettre sur la bonne piste ?

    Merci

    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    15 juin modifié
    Bonjour,

    Les espaces ne sont pas importants, parfois ils sont mêmes tous supprimés. 

    Pour la date en php, c’est une chaîne qui détermine le format. Lire https://www.php.net/manual/fr/datetime.format.php

    Bonne recherche. 
    The f....g boss
  • TipOTipO Messages 188Moderateur
    Bonjour,
    merci @fred.
    Pour la date, j'ai fini par trouver comment supprimer les zéros. Pour les 1er, la mise en exposant attendra que je progresse…
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 709Administrateur
    Bonjour @TipO ,
    Je ne pense pas que ce soit possible avec le format date. Une expression régulière devrait faire l’affaire. 

    The f....g boss
  • TipOTipO Messages 188Moderateur
    18 juin modifié
    Bonjour @fred,
    les expressions régulières sont un vaste domaine que j'ai abordé à la marge.
    Pour la date, ça semble tourner –si j'ai bien compris, autour d'un formatage des nombres ordinaux en fonction du contexte local (us, fr…) Trop loin de mes compétences hélas.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
Connectez-vous ou Inscrivez-vous pour répondre.