Responsive File Manager vide

Bonjour à tous !

Décidément, les petites difficultés s'accumulent depuis la migration de mon serveur personnel au serveur de production  :s

Je me rends compte que sur la version du site du serveur personnel, l'appel à l'intégration d'une image affiche bien le Responsive File Manager, mais qu'il n'en est rien sur la version de production. La fenêtre s'affiche, mais elle reste désespérément vide.

Pour mémoire, j'ai dû désactiver l'option "URL intelligentes" pour que le site fonctionne par ailleurs correctement.

Quelqu'un a-t-il une idée ?

Commentaires

  • randoorandoo Messages 2Membre
    Bonjour,

    J'ai eu le même soucis que vous. J'ai passé mon hébergement en php 7.4 au lieu de php 8 et ca a corrigé le problème.

    A+
    Ranoo
  • fredfred Messages 671Administrateur
    @randooa tout à fait raison, il manque une mise à jour mineure pour faire tourner le gestionnaire de fichiers sous php 8.
    The f....g boss
  • FabienFabien Messages 26Membre
    Bonjour,

    Merci pour la réponse !

    Je suis en effet en PHP 8.0.18, mais pour le moment, mes tentatives pour basculer en 7.4 (présent sur le serveur Linux, installé par cPanel) sont infructueuses. En ajoutant cette ligne de configuration :angry:

    AddHandler application/x-httpd-php74 .php

    et actualisant une page du site, il me demande de la télécharger :s

    J'avais installé cPanel pour me faciliter la vie, mais je ne parviens pas à accéder à l'interface web :s

    Une idée pour la bascule en PHP 7.4 ?
  • fredfred Messages 671Administrateur
    Bonsoir
    Dans le cpanel de l’hébergeur, il doit exister une possibilité de modifier la version de php par dossier. 
    Peut-être faudrait-il interroger ne support pour l’activer. 
    The f....g boss
  • TipOTipO Messages 150Moderateur
    Bonjour,
    Dans le cpanel de l’hébergeur, il doit exister une possibilité de modifier la version de php par dossier. 
    Peut-être faudrait-il interroger ne support pour l’activer.

    J'ai tenté avec mon hébergeur Archive-Host, qui m'a répondu qu'il n'était pas possible de faire fonctionner 2 versions différentes de Php chez lui. Du coup, j'attends la V12 pour passer en production.


    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 671Administrateur
    Bonjour,
    Peut-être que la modification sera intégrée dans 11.4, v12 est encore lointaine.
    @TipOtu  peux tenter de modifier les lignes 6 et 7 de config.php dans le dossier core/vendor/filemanager/config comme ceci et faire un retour  ? 

    The f....g boss
  • FabienFabien Messages 26Membre
    Là est tout mon problème !
    Mon hébergeur fournit une machine virtuelle avec un GNU/Linux et n'a rien fourni concernant le web - si, si, c'est possible. J'avais donc installé cPanel en espérant pouvoir administrer le serveur via une interface web, mais celle-ci ne fonctionne pas. D'où l'idée de passer par la modification de .htaccess du dossier, mais il faut encore voir comment activer PHP 7.4 en mode console et désactiver PHP 8 :s

  • TipOTipO Messages 150Moderateur
    Bonjour,
    Installation fraiche de la 11400-dev, modification faite, tout fonctionne sous Php 8.1
    J'ai testé le gestionnaire de fichiers, la personnalisation de différentes zones, l'administration, RAS !!!
    @Fabien, cela peut-il te servir ?
    La gestion des versions de PHP est basée sur l'outil PHP Selector de CloudLinux et cela se fait sur le compte.
    cPanel propose avec MultiPHP de définir par domaine mais ce n'est pas compatible avec le système actuel.


    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 671Administrateur
    Voilà qui confirme l’intégration dans 11.4 et la compatibilité php 8.1. 

    The f....g boss
  • FabienFabien Messages 26Membre
    @TipO
    Merci pour cette confirmation ! Est-il possible de faire cette mise à jour manuellement ? Je suis en 11.2.04 et la mise à jour via le panneau d'administration plante sur la mise à jour :s
  • TipOTipO Messages 150Moderateur
    Bonjour,
    sur mes maquettes locales, je remplace les dossiers 'core' et 'module', ainsi que les fichiers de base situés à la racine (index.php, change.md, licence…) par ceux de la nouvelle version. Puis j'y copie le dossier 'site' de ma version précédente. Si ça coince, il faut vérifier le fichier 'htaccess'.
    Pour finir, je passe en revue la configuration, les personnalisations éventuelles. Jusqu'à présent, cette méthode a bien fonctionné.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • FabienFabien Messages 26Membre
    5 mai modifié
    @TipO
    Merci ! La manipulation a bien marché, mais j'ai trois problèmes désormais - une vraie malédiction :angry:

         • la galerie de médias s'affiche bien. Toutefois, lorsque je me rends dans dossier /galerie, les aperçus des images/icones que j'avais chargées auparavant s'affichent bien, mais dans le sous-dossier /photos que j'avais créé, ZwiiCMS compte bien 7 fichiers images, mais elles n'apparaissent pas en miniature - rien ne s'affiche. J'ai vérifié les droits des fichiers sur le serveur, ils sont en 777 pour le moment, et bien entendu, les photos de ce dossier déjà insérées dans les articles s'affichent bien. Une idée ?

         • j'ai essayé de téléverser des images d'environ 2 Mo. Mais au moment du téléversement, j'ai un "Error Internal Server Error". Je suis allé modifier le paramètre upload_max_filesize de php.ini pour le passer à 10 Mo, mais le problème persiste. Une idée ?

         • juste après avoir remplacé les dossiers /core et /module, j'ai actualisé la page et j'ai eu furtivement un message d'erreur indiquant qu'il y avait un problème avec "font", sans avoir eu le temps de lire quoi que ce soit d'autre. Je me rends compte que les titres des menus sont désormais écrits de manière déséquilibrée. Après investigation, les polices droid-serif-2 et fira-sans apparaissent avec des boutons grisés, bien qu'ils soient affectés au texte et aux menus/titres respectivement. Une idée ?



    Merci d'avance !
    Post edited by Fabien on
  • fredfred Messages 671Administrateur
    • Peut-être que la suppression des miniatures de photos/ dans le dossier thumbs réglera le problème. En temps normal, on n'a jamais besoin de toucher aux permissions, surtout avec 777 qui donne tous les droits à n'importe qui. Dans RFM les droits par défaut sont 777 pour les dossiers et 755 pour les fichiers.
    • Dans RFM il existe un fichier config qui limite la taille des fichiers à 20000 Mo soit 20 Go (symbolique d'ailleurs), valeur à vérifier.
    • Quant aux polices, il se peut que la mise à jour n'ait pas aimé un paramètre particulier dans l'une des fontes, dommage que tu n'aies pas vu l'erreur. Dans le thème, il faut contrôler si la police affectée au menu est correcte.


    The f....g boss
  • FabienFabien Messages 26Membre
    @fredMerci pour ces conseils !

    • Je viens de supprimer les miniatures dans le dossier /site/file/thumb/galerie/photos, mais les miniatures des images contenues dans le dossier /site/file/source/galerie/photos ne sont pas générées :s

    • J'ai téléversé une nouvelle image dans le dossier /site/file/source/galerie/photos, mais j'ai de nouveau eu une "Internal server error" : le fichier est pourtant bien téléversé, je l'ai bien vu en FTP.

    • Pour la police de caractères, j'ai finalement opté pour un changement de police de caractères dans la liste, depuis la console d'administration. Une feuille de style personnelle était à l'origine de l'affichage de mon précédent post. Ce problème est donc réglé, mais pas les autres :s

    D'autres idées pour le RFM ?
  • fredfred Messages 671Administrateur
    Dans tous les cas, la copie des fichiers par RFM va automatiquement créer les miniatures lors de leur affichage. Mieux vaut éviter le FTP.
    C'est peut-être un bug de RFM lié à PHP 8.1
    Je teste et reviens vers toi. 
    The f....g boss
  • augrasaugras Messages 84Moderateur
    J'ai souvenir qu'à une époque,  après avoir versé des photos/images via ftp, il fallait ouvrir RFM et visiter les dossiers de ces images pour que RFM génère les miniatures : ce que je lis m'a rappeler ça.
  • FabienFabien Messages 26Membre
    @augras
    Merci pour le conseil !
    C'est ce que je fais, mais les miniatures n'ont pas été générées, même en me rendant dans le dossier en question - les permissions sont en 777 pourtant :

    L'ensemble des fichiers est bien compté, leur poids bien calculé, mais les fichiers n'apparaissent cependant pas. GRRRRRRR !
  • fredfred Messages 671Administrateur
    Les extensions php requises son bien installées ? Cf la doc pour la liste. 
    The f....g boss
  • augrasaugras Messages 84Moderateur
    Pas de bloqueur du pub installé par hasard ? Ils jouent des tours inattendus, comme par exemple ce que tu décris.
  • TipOTipO Messages 150Moderateur
    Bonjour,
    je confirme la suggestion de @augras.
    J'ai un filtreur de connexions qui empêche par défaut le fonctionnement des scripts externes, le File Manager n'affiche quasiment rien. Je dois autoriser les appels à ces sites externes pour qu'il fonctionne correctement.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • FabienFabien Messages 26Membre
    16 mai modifié
    Bonjour,

    Merci pour vos réponses !

    Malheureusement, après plusieurs essais sur des navigateurs différents, des ordinateurs différents et un smartphone, le RFM reste désespérément vide, bien que le nombre de fichiers et leur poids total soit bien affiché.

    De plus, il s'avère que les modules PHP requis n'étaient pas installés. Je l'ai donc fait sur le serveur (mbstring, zip, GD, XMLwriter, les autres étaient déjà présents). Pas de changement de comportement 

    D'autres idées ?

    Merci d'avance !
  • fredfred Messages 671Administrateur
    Je pense à une origine identique au problème de mise à jour, des permissions. 
    Tu pourrais m’ouvrir un compte admin, je tenterai d’y voir plus clair (en MP ;) )
    The f....g boss
Connectez-vous ou Inscrivez-vous pour répondre.