Possible bug sur les fontes

FM69FM69 Messages 14Membre
25 juil. modifié dans [V11] Un bug découvert ?
Bonjour @fred,

J'ai ces messages qui apparaissent sur mon site Radio by Le Site de Flo quand j'essaye de changer une fonte depuis l'interface dédiée :

Warning: file_put_contents(site/data/fonts/fonts.html) [function.file-put-contents]: Failed to open stream: Aucun fichier ou dossier de ce type in /home/users/00/36/78/home/www/core/module/theme/theme.php on line 1250

Warning: file_put_contents(site/data/fonts/fonts.css) [function.file-put-contents]: Failed to open stream: Aucun fichier ou dossier de ce type in /home/users/00/36/78/home/www/core/module/theme/theme.php on line 1252

Warning: Cannot modify header information - headers already sent by (output started at /home/users/00/36/78/home/www/core/module/theme/theme.php:1250) in /home/users/00/36/78/home/www/core/core.php on line 2868


Pour le moment, j'ai testé avec le theme.php d'origine (les "line" en erreur sont 2050 et 2052) et le theme.php modifié du fil précédent (lien du post). Ce sont d'autres "line", pas intéressantes dans ce cas, puisque ce second fichier est ancien.

J'avais la fonte Ubuntu qui ne s'affiche plus pour le moment, mais sans message d'erreur Chrome développement en prod... J'ai testé en mettant la fonte Verdana, elle se met bien, mais ce message d'erreur apparait à chaque fois en fond blanc !

Seules les deux premières lignes de cet erreur apparaissent constamment en haut de page sur l'interface admin, rubrique "Thèmes".

Merci à toi !

FM69
Post edited by FM69 on

Commentaires

  • FM69FM69 Messages 14Membre
    25 juil. modifié
    Je crois avoir résolu mon problème et je partage ma résolution ici.

    Sur mon espace web, le dossier "fonts" (site/data/fonts/fonts.html) ne s'est pas créé et n'existait donc pas. Le création de ce dossier permet aux fichiers fonts.css et fonts.html de se générer automatiquement ensuite... Il n'y a plus d'erreur !

    Du coup, ma question est désormais : Est-ce que tout le monde dispose de ce dossier actuellement ou ai-je été le seul à devoir recréer ce dossier ?

    Ce qui amène à une dernière chose : Est-il nécessaire d'ajouter le dossier vide "fonts" à site/data pour éviter cette erreur sur une prochaine maj ?

    Je précise que je ne me suis pas amusé à supprimer ce dossier avant l'erreur  ;), surtout pas à cet endroit là... C'est quand même le dossier de sauvegarde des pages du site  B)

    Merci !

  • TipOTipO Messages 201Moderateur
    Bonjour,
    je n'ai eu aucun problème avec les fontes dans toutes les maquettes installées en local ; pour celle en ligne non plus.
    Peut-être faire un essai avec une installation fraîche, vérifier si ces erreurs se produisent aussi.

    On voit là un autre avantage notable de ZwiiCMS, on peut l'installer à volonté sans difficulté majeure.
    Débutant explorateur. ZwiiCMS installé sur serveur local : MAMP Mac, Php 7.4.2
    Migration en préparation…
  • fredfred Messages 730Administrateur
    Bonsoir,
    Le dossier fontes est créé à l’installation, cependant je vérifierai que son existence est bien contrôlée afin de le créer à la volée. 
    A suivre. 
    The f....g boss
  • fredfred Messages 730Administrateur
    Étrangement, le dossier des fontes est créé à l'installation et non lors des mises à jour, les erreurs s'expliquent donc.

    Le script générant les deux fichiers de fontes pour les aperçus effectuera la création de ce dossier en cas d'absence. Comme il est appelé avec la liste des polices, son affichage (thème / fontes) corrigera le problème une fois pour toute.

    À suivre sur cette branche que je publierai ce week-end.
    The f....g boss
  • fredfred Messages 730Administrateur
    Bonjour,
    Mise à jour faite.
    The f....g boss
  • lemimilemimi Messages 47Membre
    Hello,

    Merci Fred, cela s'est passé sans aucun problème pour moi :-)

    Au plaisir... Michel
Connectez-vous ou Inscrivez-vous pour répondre.