ZwiiCMS version 11.5.11 est disponible au téléchargement.
Cette version assure la compatibilité avec php 8.1 en corrigeant de nombreuses erreurs liées à des dépréciations de fonctions et à des modifications de comportement.

ZwiiCMS 12.0.00 échanges sur les évolutions

fredfred Messages 871Administrateur
dev-001

Il sera désormais possible de configurer le proxy dès la fenêtre d'installation, indispensable sur les gros réseaux locaux. 

Il y a un effet d'accordéon invisible sur la capture.

URL de la branche https://forge.chapril.org/ZwiiCMS-Team/ZwiiCMS/src/branch/11600

Post edited by fred on
The f....g boss
«13

Commentaires

  • TipOTipO Messages 289Moderateur
    Bonjour,
    je teste sur MAMP
    - installation RAS
    - export-import du site depuis une version 11.5.06

    Seuls trois modules apparaissent dans le Gestionnaire de modules
    - Blog
    - Formulaire
    - Recherche

    Ces modules ne sont pas reconnus, alors que leurs dossiers ont bien été importés
    - Agenda
    - Forum
    - Galerie
    - News
    - Redirection

    Dans quelle direction chercher pour comprendre où est le souci ?

    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • fredfred Messages 871Administrateur
    Bonjour,
    L'import par la configuration effectue un import des données et pas des modules eux-mêmes. Sûrement une piste. 

    dev002

    En vérifiant la fonction, j'ai trouvé un bug d'affichage lorsque les données d'un module non installé sont importées, c'est corrigé. Il faudra retesté les différentes conditions.

    Enfin, j'ai augmenté la largeur des boutons de sélection de mode dans la gestion des modules.


    Attention, les modules produits comme statislite ne sont plus maintenus.
    The f....g boss
  • fredfred Messages 871Administrateur
    dev003

    Suppression de la traduction auto Google Trans
    The f....g boss
  • CarlosRabilaCarlosRabila Messages 23Membre
    Bien fait.. 
  • fredfred Messages 871Administrateur
    Je pense avoir trouvé la solution afin de permettre la traduction native de l'interface sans avoir à éplucher le code et en extraire les chaînes de caractère. Il suffira de modifications simples au niveau des templates. Donc c'est en cours.... 
    The f....g boss
  • fredfred Messages 871Administrateur
    29 août modifié
    dev005

    La capture d'écran Open Graph n'appelle plus l'API de Google, elle utilise désormais https://app.screenshotapi.net/ 

    Pour ce faire, il faudra ouvrir un compte gratuit et saisir la clé d'API. 100 requêtes sont autorisées par mois, largement suffisant.



    Post edited by fred on
    The f....g boss
  • lemimilemimi Messages 63Membre
    Bonjour,

    Ai transféré par FTP le dossier site de lemimi.fr sur celui de test; https://www.lemimi.fr/test-zwii/ , avec les modules statislite et mon Tarteaucitron.
    Tout s'est installé sans problème et fonctionne nickel.

    Juste un problème, suis obligé de cliquer plusieurs fois sur le bouton  de déconnexion et relancer plusieurs fois la commande avant de sortir du mode admin.
    Cela le faisait aussi avec la version toute fraîchement installée.

    Bonne soirée et gros mercis pour le travail... Michel

  • fredfred Messages 871Administrateur
    Bonjour Michel,
    La commande de déconnexion supprime des cookies sur ton poste, le problème que tu rencontres est certainement lié à cela, je n'ai rien constaté de mon côté.
    Attention, à partir des évolutions publiées ce weekend, les modules anciens, comme statislite ne seront plus supportés à cause de changement au niveau de la syntaxe de la template ico.
    Ces modules, dont ceux du défunt SL ne seront pas mis à jour.
    Bonne soirée
    The f....g boss
  • TipOTipO Messages 289Moderateur
    5 sept. modifié
    Bonjour,
    un dysfonctionnement que je découvre.
    Version installée : 11.6.00-dev006
    Soit une page à supprimer, 
    - la suppression via le bouton ad hoc de la barre d'administration ne fonctionne pas, le dialogue de confirmation Non/Oui n'agit pas
    - en mode édition de la page, la suppression via le bouton "corbeille" fonctionne correctement


    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • fredfred Messages 871Administrateur
    Bonsoir,
    Pour ceux qui suivent le développement, on peut désormais installer Zwii dans une langue étrangère. Lors de l'installation, la première bannière demande la langue, l'interface bascule dans la nouvelle langue à partir de l'écran d'installation classique (postinstall).
    L'espagnol est fait à 95% merci à @CarlosRabila
    L'anglais suivra.
    The f....g boss
  • fredfred Messages 871Administrateur
    Suite au réaménagement complet de la gestion, ce sera donc une version 12.0.
    The f....g boss
  • TipOTipO Messages 289Moderateur
    Merci @Fred. À tester donc.
    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • ThispyThispy Messages 70Membre
    Bonjour,

    Beaucoup de changement en vue..

    Félicitation.
  • TipOTipO Messages 289Moderateur
    Bonjour,
    il y a quelques jours, j'ai installé la version 12.0.00-dev009 sur une maquette en ligne. La page de configuration affiche
    Version installée : 12.0.00-dev009
    Version en ligne  : 11.2.00-dev014
    J'essaie de suivre les évolutions de cette branche, mais du coup, la dernière en date n'est pas proposée.
    Faut-il toujours en passer par ftp pour cette branche ?
    Merci.

    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • fredfred Messages 871Administrateur
    Bonsoir
    Il doit y avoir une erreur dans la numérotation retournée par l’API.  Nous sommes bien en version 12.0.00.  
    Je dois mettre la main à l’amélioration des fonctions plugin, demain sûrement, je mettrai la version à mettre à jour. 
    Merci de suivre le projet, je me sens un peu seul ;) 
    The f....g boss
  • TipOTipO Messages 289Moderateur
    Bonjour,
    Merci de suivre le projet, je me sens un peu seul

    je fais de mon mieux, c'est le moins que je puisse compte tenu de mon intérêt pour Zwii et la qualité du produit que tu nous offres ;)

    Je regrette de ne pouvoir aider au niveau du code, je reste un petit amateur resté à la surface des choses. Le temps me manque pour approfondir mon apprentissage, sans compter l'énergie déjà bien absorbée par d'autres projets.
    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • fredfred Messages 871Administrateur
    Bonjour @TipO
    La variable de l'API est désormais correcte. On est en dev015, je ferai la mise à jour dans la journée.
    On se rapproche de la fin :) 
    The f....g boss
  • TipOTipO Messages 289Moderateur
    re,
    impec @fred, pour autant que je puisse m'en rendre, tout fonctionne.
    Version installée : 12.0.00-dev015
    Version en ligne  : 12.0.00-dev015

    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • lemimilemimi Messages 63Membre
    Hello,
    Je viens de faire une installation neuve en espagnol... aussi facile qu'en français !
    Juste quelques mots et phrases qui apparaissent toujours en français, formulaire d'installation et bandeau du mode admin.
     voir les images ci-dessous:
    et


    Bonne soirée à tous... Michel
  • fredfred Messages 871Administrateur
    Bonjour @lemimi
    En effet, il va falloir faire la chasse, il se trouve que mes moulinettes n'ont pas toujours bien fonctionné. 
    Sur la totalité du CMS sans tenir compte des modules, il y a presque 500 lignes d'étiquettes et d'aide.
    Les traductions en espagnol sont assurées par @CarlosRabila que je remercie pour son aide.
    Je pense que l'anglais devrait être la prochaine.

    The f....g boss
  • TipOTipO Messages 289Moderateur
    19 oct. modifié
    Finalement, je rencontre quelques soucis avec la V12.
    1. Les URL intelligentes plantent le site
    The requested URL was not found on this server.
    Additionally, a 404 Not Found
    error was encountered while trying to use an ErrorDocument to handle the request.
    2. La suppression ou la modification de pages  orphelines, qui contenaient des modules le module Statislite (supprimés depuis) n'est plus possible. J'ai dû mal m'y prendre sur ce coup.

    Edit: le problème survient après suppression de plusieurs modules, qui ne sont plus compatibles avec la V12.
    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • fredfred Messages 871Administrateur
    J’ajoute la traduction du site qui est liée à la configuration au lieu de l’être à l’usager. Je suis dessus. 

    Concernant les modules, ce sera en effet un problème avec les modules qui ne sont plus maintenus. 
    Je ferai des tests pour me rendre compte d’où ça coince. 


    The f....g boss
  • TipOTipO Messages 289Moderateur
    21 oct. modifié
    Bonjour,
    en attendant, dans module.json et page.json, j'ai supprimé les entrées correspondant aux modules inexistants.

    Ajout : j'ai résolu le problème des URL intelligentes. Le fichier .htaccess avait 664 comme permissions. Après correction en 644, c'est rentré dans l'ordre.
    Post edited by TipO on
    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • fredfred Messages 871Administrateur
    Bonjour Tipo,

    Okay pour htaccess, je checkerai les droits.

    On passe en dev016, la langue de l'interface est désormais définie au niveau de l'utilisateur et non de la configuration. 

    The f....g boss
  • TipOTipO Messages 289Moderateur
    Bonjour,
    les tags de version sont bizarres et aucune mise à jour n'est proposée.
    Cf. copies d'écran avant et après mise à jour


    Ceci dit, elle fonctionne sur ma maquette en ligne.  :bee:

    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • fredfred Messages 871Administrateur
    :blush:

    Dev018 corrige un bug d'installation, un drapeau de langue seul, et la suppression de la langue de site sélectionnée.

    The f....g boss
  • EricEric Messages 40Membre
    Bonjour,

    Il me semble que Zwii fait appel  à des polices de caractères situées sur le site fontawesome (j'espère ne pas dire de bêtses).
    Est-ce qu'on ne pourrait pas avoir les polices dans Zwii plutôt (pour qu'il n'y ait plus du tout d'appel à des services extérieurs) ?

    (Je suis toujours aussi fan de ce CMS après des années d'utilisation : vraiment merci pour ce que vous faites !)
  • TipOTipO Messages 289Moderateur
    Bonjour,
    Les polices sont appelées depuis le site CDNFonts. Il est possible toutefois d'installer ses propres polices sur le serveur.
    Les évolutions de la gestion des fontes sont évoquées dans plusieurs discussions



    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


  • EricEric Messages 40Membre
    MInce ! Ca fait un bon moment que je n'avais pas changé la mise en page (ou que je clique tellement rapidement sur ce qui m'intéresse) que je n'avais même pas vu l'apparition du bouton "Font" !!!
    C'est super !!!

    J'ai pu enlever du coup toutes les polices importées facilement !
  • TipOTipO Messages 289Moderateur
    Bonjour,
    pour info @fred Tout baigne. Merci Boss !

    Version installée : 12.0.00-dev018
    Version en ligne  : 12.0.00-dev018




    Débutant explorateur de ZwiiCMS.
    Maquettes locales (MAMP, Php 7.4.2), pré prod en ligne sous Php 8.1


Connectez-vous ou Inscrivez-vous pour répondre.