[12.1.0.1 ] Bannière non cliquable dans le header

rogerroger Messages 22Membre
20 janv. modifié dans [v12] Un bug découvert ?
Je remarque dans une installation fraîche (donc sans aucunes modification) avec la bannière placée dans le Header:

Si la bannière est placée dans le site elle renvoie bien sur la page d'accueil de celui (avec le titre du site à ne pas afficher dedans).

Le "bug" constaté:
Si l'on place la bannière en dehors du site (theme/header) celle ci n'est plus cliquable est ne ramène plus vers la page d'accueil du site.
La cause du problème:
C'est si l'on décide de masquer le titre du site à cet endroit là cela fait sauter la redirection vers la page d'accueil si on clique sur l'image.




Toujours aller de l'avant, ne pas regarder derrière soi telle est une vie belle, bien remplie.

Commentaires

  • fredfred Messages 1,043Administrateur
    La base :) 

    C'est corrigé dans cette branche à paraitre dans les jours à venir : 

    https://forge.chapril.org/ZwiiCMS-Team/ZwiiCMS/src/branch/12102

    Merci du signalement
    The f....g boss
  • rogerroger Messages 22Membre
    20 janv. modifié
    @fred hihihihi

    Tu te doute bien que j'ai toujours les mêmes défauts :)
    Sur le site qui ne me sert qu'à visualiser les bugs et les corriger, j'ai mis en Rouge la zone cliquable pour plus de compréhension visuelle.

    Ta première correction c'est OK (elle à rétabli le lien cliquable à cet endroit) réinjectée aussitôt dans ma version en "prod"
    ;) mais ça suffit pas car............le lien cliquable activé est dans une zone bien définie en largeur/hauteur (largeur en fonction du titre choisi pour le site)
    Ceci est l'endroit du titre cliquable: <span id="themeHeaderTitle">Titre générique du cms à l'installation</span>
    et donc si on ne met pas de titre et bien la zone cliquable ne se voit pas tellement elle est riquiqui, donc provisoirement (sur un second site chez moi) j'ai injecté dans le css perso ce qu'il faut pour que la zone cliquable dans la bannière en dehors du site occupe toute la surface du header et de couleur transparente pour ne pas masquer l'image en dessous. (à mettre dans le css concerné dans le zwii officiel bien entendu)

    /* lien invisible de la bannière */
    header span { background-color: transparent; width: 100%; height: 100%; margin: auto;}

    Toujours aller de l'avant, ne pas regarder derrière soi telle est une vie belle, bien remplie.
  • fredfred Messages 1,043Administrateur
    20 janv. modifié
    Voilà pourquoi je n’ai pas publié :) 
    The f....g boss
  • fredfred Messages 1,043Administrateur
    Désolé, je ne reproduis pas le second défaut, la bannière est cliquable, dans et au-dessus du site, avec ou sans le titre du site.
    The f....g boss
  • rogerroger Messages 22Membre
    Les essais que je reporte ne sont vérifiables bien entendu que sur le site qui  est hébergé chez moi

    Regardes ici http://website-distribution.com/zwiicms12101/ j'ai enlevé le css (qui rend le carré rouge visible cliquable) dans la bannière au dessus du site, et sans le titre du site.

    La zone cliquable est tellement minuscule comme je l'ai marqué plus haut qu'il faut se mettre "plein centre dans l'image" pour que le pointeur puisse la repérer.
    En enlevant sur mon site test la couleur rouge ainsi sa taille du css perso
    /* lien dans le header */
    /*header span {
      background-color: red;
      width: 400px;
      height: 50px;
    }*/
    L'on arrive à ce que tu vois sur place chez moi.

    Le css pour le span est celui que je t'ai donné et qui lui et mis en place sur mon second site identique à  celui de test
    Toujours aller de l'avant, ne pas regarder derrière soi telle est une vie belle, bien remplie.
  • fredfred Messages 1,043Administrateur
    Ton site de test devrait afficher la version du correctif, à savoir 12.1.02 dans le pied de page.

    The f....g boss
  • rogerroger Messages 22Membre
    Pas forcément pour la raison expliquée par mp car un correctif peut aussi être placé directement dans une version antérieure sur le serveur tant que celle ci fait partie de la même branche avec la même architecture.
    Toujours aller de l'avant, ne pas regarder derrière soi telle est une vie belle, bien remplie.
  • fredfred Messages 1,043Administrateur
    Second essai ce matin, la bannière est bien cliquable hors du site dans le site, avec ou sans titre.

    En tout cas merci pour ce report de bug que personne n'avait vu avant.
    The f....g boss
  • rogerroger Messages 22Membre
    De rien @fred c'est un bug relativement ancien que je connaissais bien.

    Dans les V9 etc il était déjà là mais peu de personnes pensent à mettre leur bannière en dehors du site (l'habitude générale est que l'on place sa bannière dans le site), peu aussi peuvent relever ce bug s'ils ne testent pas cette partie là de personnalisation d'un ZwiiCMS.
    Toujours aller de l'avant, ne pas regarder derrière soi telle est une vie belle, bien remplie.
  • ThispyThispy Messages 89Membre
    Héhé, @roger qui est de retour et déjà dans les codes !

    Heureux de te revoir...

    Cordialement,
Connectez-vous ou Inscrivez-vous pour répondre.