Primo Installation : Données absentes

Bonjour,

Je viens de décompresser ZwiiCMS sur mon serveur LAMP. Quand je lance l'installation j'ai "donnée absentes" dans un encadré rouge et aucun choix. Je crois qu'il y a un souci au niveau de l'archive (que j'ai téléchargé et décompressé 2 fois, j'ai même tenté la version précédente en vain)

Voici exactement ce que dit l'encadré rouge
Données absentes, restauration de| admin | blacklist | config | core | fonts | module | locale | page | theme | user | languages | admin | blacklist | config | core | fonts | module | locale | page | theme | user | languages |

Merci d'avance pour votre aide


Commentaires

  • fredfred Messages 1,043Administrateur
    Bonjour,

    Avez-vous eu une fenêtre avec le choix de la langue et le paramétrage du compte admin ?

    Vous devriez vérifier les permissions sur les dossiers dans site.



    The f....g boss
  • ortesseortesse Messages 10Membre
    ah oui c'est certainement les permission ... je regarde et je reviens...
  • ortesseortesse Messages 10Membre
    Désolée je n'avais pas fait mon chown www-data en récursif.

    Merci j'ai au moins pu m'en rendre compte

    Sinon pas de doc? J'ai un peu de mal à trouver certaines choses. En tout cas il me fallait un CMS léger qui tourne de façon fluide sur mon serveur personnel pour promouvoir et présenter mon activité, ça semble correspondre.

    Merci
  • augrasaugras Messages 206Moderateur
    Bonjour @ortesse ,
    Il y a une documentation https://doc.zwiicms.fr/
    Mais suite à la publication de la version 12 elle est en cours de mise à jour et plus accessible : il y a en effet pas mal d'évolutions et les explications et captures d'écran ne correspondaient plus.
    Mais pour un usage courant ZwiiCMS est suffisamment intuitif pour ne pas poser de soucis.
    Il y a une chose qui est déconcertante avec l'introduction de la gestion des langues : le titre du site et plusieurs paramètres sont accessibles via le bouton des langues... puisque doivent être définis par langue utilisée.
    Bonne découverte !
  • ortesseortesse Messages 10Membre
    Ok. Oui j'ai pu me débrouiller, mais il me faudra surement accès à la doc pour peaufiner le tout
  • ortesseortesse Messages 10Membre
    Bon j'essai de comprendre pour le formulaire de contact. Est-ce qu'il prend le smtp de Gmail -j'y arrive pas - car j'ai des soucis de récupération de mes identifiants OVH pour mon adresse mail.

    J'ai toujours galéré pour créer un serveur mail donc pour le moment si je peux recevoir mes notifications de contact sur une de mes boites gmail ça serait bien
  • ortesseortesse Messages 10Membre
    Bon, j'ai retrouvé l'accès à mon adresse mail OVH, impossible d'envoyer un formulaire de contact, et là, c'est très embêtant vu que je propose des services de création et d'impression 3D et bientôt de meuble sur-mesure à l'aide d'une fraiseuse numérique

    Y'a t'il un module apache ou PHP que je devrais activer côté serveur ?

    J'ai aussi un souci -là, c'est ma faute - pour les URL simplifié, quel module apache doit être activé ?

    Je commence sinon à prendre en main ce CMS, avec un peu de CSS j'arrive à ce que je veux sans avoir la lourdeur de WordPress, puis ça me permet de retrouver quelques bases de CSS =)

  • augrasaugras Messages 206Moderateur
    25 janv. modifié
    Ma réponse ne va pas être d'un grand secours !

    Mais je pense que le serveur local est responsable de tes soucis de mails, et autres.
    Je ne comprends pas ce besoin d'installation locale, surtout avec Zwii : tu l'installes chez ton hébergeur dans un dossier pour faire tous les tests que tu veux.
    Quand tu as le résultat escompté tu peux soit renommer ton dossier avec un nom définitif, soit en créé un nouveau où tu copies le contenu de celui de test.
    Tout est en adresses relatives dans zwii (sous réserve que toi également tu mettes des adresses relatives quand tu fais un lien) et ça passe tout seul.
    Chez ton hébergeur, sans rien faire, les mails sont à priori fonctionnels.

    J'ai joué aussi à une époque avec un serveur local et en ai déduis que c'était bien s'embêter pour pas grand chose.
    Même avec des installation plus complexes, avec base de données par exemple, je fais tout directement sur mon hébergement, et pas de soucis particulier, bien au contraire.

    Philippe
  • fredfred Messages 1,043Administrateur
    Philippe a raison, en local, il faut installer un serveur de messagerie. Configurer le SMTP Gmail ne fonctionnera pas non plus, l'authentification Google est différente d'une authentification standard.

    Herberger votre projet en ligne vous évitera bien des problèmes. Chez Obambu, l'hébergement est à 17,88€ à l'année pour 50 Go avec un nom de domaine offert. Le lien pour y accéder est ici en vous abonnant par ce lien, vous soutenez le développement de Zwii qui est distribué gratuitement à la communauté.
    The f....g boss
  • ortesseortesse Messages 10Membre
    J'ai déjà un hébergement plein d'ailleurs assez cher, je prendrai sur le lien que vous m'avez fourni car les prix sont convenables.

    C'est juste une page avec une page d'accueil, un mini blog, une galerie et quelque lien qui me sont nécessaires le temps de voir comment ça évolue. En gros c'est une vitrine avec contact.

    Parce qu'ensuite, je passerai sur Odoo si ça devient viable (donc avec gestion plus poussée)  donc oui là un hébergement.


    Mais je ne comprends pas le SMTP est fonctionnel ou non? J'ai mes identifiants de messagerie OVH (donc avec mon nom de domaine). La sécurité est bien moindre que celle de Google et j'ai déjà réussi à me servir d'application en ligne de commande pour envoyer des notifications par mail en SMTP avec OVH.

    C'est basé sur quoi le module mail et son option SMTP? 

    Car c'est tout ce qu'il me manque, le formulaire ça me parait pas complet de mettre que messenger, whatsapp comme alternative de contact
  • fredfred Messages 1,043Administrateur
    C’est basé sur sendmail, une fonctionnalité de php.  
    The f....g boss
  • ortesseortesse Messages 10Membre
    ok merci

  • ortesseortesse Messages 10Membre
    J'avais oublié de vous dire que c'est bon pour le SMTP. :)Une galère de terminée, une autre arrive, j'essaie de profiter du module snipcart. Il faut downgrader à la V11 pour qu'il fonctionne ou bien ce n'est pas necessaire?
  • fredfred Messages 1,043Administrateur
    Le module snipcart est une grosse bouse à installer. Même en version 11.5 le fonctionnement est incertain.

    The f....g boss
Connectez-vous ou Inscrivez-vous pour répondre.